[Bug 1635] Fatal: Read Error: Could not read or parse the JNLP file

bugzilla-daemon at icedtea.classpath.org bugzilla-daemon at icedtea.classpath.org
Mon Jan 6 09:05:07 PST 2014


Andrew Azores <aazores at redhat.com> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED

--- Comment #13 from Andrew Azores <aazores at redhat.com> ---
Thank you very much for providing this!

This file:
- Works fine on Fedora 19 with IcedTea-Web 1.5pre, but has to use the
MalformedXML parser for it
- Fails with the exact error you are seeing on Ubuntu 13.10 VM
- Fails with the same error in Fedora 19 with IcedTea-Web 1.4

Something I noticed is that 'file -bi' shows the charset for your JNLP file as
utf-8 whereas most other known-to-work JNLP files are us-ascii (and other known
utf-8 ones are specifically for testing difficulties in parsing!). Wondering if
this had something to do with it, I tried 'iconv -f UTF8 -t US-ASCII' on the
file to see if it could be converted to ASCII. The result: "iconv: illegal
input sequence at position 0".

So it would appear that this JNLP's encoding is causing problems for the parser
used in 1.4. Once 1.5 is out and available for Ubuntu, you should be able to
use the applet as expected.

In the meantime, I have a stopgap solution that you can use. Ensure that you
have 'iconv' installed and in your PATH. Then, run this command: 'iconv -f UTF8
-t US-ASCII -c TARGET.jnlp > NEW.jnlp', where TARGET is the original JNLP file
and NEW is a new file name that you would like to use. This will attempt to
convert TARGET into NEW, ignoring any non-convertible characters. So, for

iconv -f UTF8 -t US-ASCII -c Downloads/Mijn-Dealingroom_check.jnlp >

You should then be able to use the applet if you launch it via the new "ascii"
version of the JNLP. Let me know if this works for you.

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20140106/b7953822/attachment-0001.html 

More information about the distro-pkg-dev mailing list