<html>
    <head>
      <base href="http://icedtea.classpath.org/bugzilla/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_ASSIGNED "
   title="ASSIGNED --- - Apps fail to run because of the nanoxml parser's strict XML validation"
   href="http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1026#c8">Comment # 8</a>
              on <a class="bz_bug_link 
          bz_status_ASSIGNED "
   title="ASSIGNED --- - Apps fail to run because of the nanoxml parser's strict XML validation"
   href="http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1026">bug 1026</a>
              from <span class="vcard"><a class="email" href="mailto:lil_tux&#64;web.de" title="Heiko &lt;lil_tux&#64;web.de&gt;"> <span class="fn">Heiko</span></a>
</span></b>
        <pre>Just to be clear, jnlp-7-mrel-spec states:

&quot;URLs in a JNLP file should always be properly encoded (also known as &quot;escaped&quot;
form in RFC 2396 Section 2.4.2), e.g., a space should be represented as %20 in
a HTTP URL. A JNLP Client must use the URL exactly as specified in the JNLP
file when making a request to the Web server&quot;

and

&quot;
request ::= href [ &quot;?&quot; arguments ]
arguments ::= key &quot;=&quot; value ( &quot;&amp;&quot; key &quot;=&quot; value ) *
&quot;

&quot;Should&quot; does not mean &quot;must&quot;. And the client must not alter the URL, which in
&lt;=icetea-web-1.3 is done by the kind-of broken nanoxml code.

The patch I use stops nanoxml from changing '&amp;' to '&amp;amp;', where nanoxml
kind-of runs amok since it tries to do the replacement everywhere, even in
URLs, descriptions and PCDATA.

Is there an easy way to test out icedtea-web-1.4? Im currently on:
dev-java/icedtea-7.2.3.9
dev-java/icedtea-web-1.3.1-r7</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are on the CC list for the bug.</li>
      </ul>
    </body>
</html>