Thomas Wuerthinger thomas.wuerthinger at
Sat Aug 3 16:29:28 PDT 2013


We would like to encourage Truffle language implementors to publish their work under an open source license. Therefore, we did not specifically mark API classes with the classpath exception but currently publish all of Graal/Truffle under GPLv2. In case you are thinking about using Graal/Truffle in the context of Facebook's Presto query engine [1], we would expect the license of Presto to be compatible with our open source license. Please let us know if this is not the case or would prevent you from using Graal/Truffle for your project.

Regards, thomas


On Aug 1, 2013, at 5:05 PM, Martin Traverso <mtraverso at> wrote:

> At the JVM Language Summit someone indicated that Graal/Truffle are
> licensed under GPLv2 with the Classpath exception. Looking at the sources,
> I can't find any file that mentions being covered by this exception. Is
> this an oversight?
> Thanks!
> Martin

More information about the graal-dev mailing list