Request for reviews (XL): 6939134: JSR 292 adjustments to method handle invocation

Christian Thalinger Christian.Thalinger at Sun.COM
Fri Apr 23 07:11:03 PDT 2010

On Wed, 2010-04-21 at 23:03 -0700, John Rose wrote:
> As suggested, I moved the adapter_conversion_ops_supported_mask into
> methodHandles_<arch>.cpp.
> Christian, I have you down as a reviewer.  Let me know if you want me
> to adjust it in any way to prepare for your changes.  For example, I
> could split the methodHandles_<arch>.hpp files so you don't have to
> put sparc-specific stuff into methodHandles.hpp.

We definitely should do that.  I will not do that in one of my current
changes as it would get too much and confusing.

I can also open a new CR for that and push it on its own.

> And, if there are no more comments on this change, I'll push it.


-- Christian

More information about the hotspot-compiler-dev mailing list