RFR (M): 7023898: Intrinsify AtomicLongFieldUpdater.getAndIncrement()

Roland Westrelin roland.westrelin at oracle.com
Tue Jun 26 00:55:04 PDT 2012

> Even so John said you can use LS I would suggest to use full name. Why not use nodes names? For a example: GetAndAdd, GetAndSet, CompareAndSwap. It is easier to understand the meaning.

Are you suggesting I drop the LS prefix as well?
I would expect it to be good for readability that the name contains a hint that all those constants are related to each other.


More information about the hotspot-compiler-dev mailing list