NPE on tiered compilation only (seeking help to narrow it down)

Uwe Schindler uschindler at
Tue Aug 25 11:19:53 UTC 2015


thetaphi at serv1:~$ java -version
java version "1.9.0-ea"
Java(TM) SE Runtime Environment (build 1.9.0-ea-b78)
Java HotSpot(TM) Server VM (build 1.9.0-ea-b78, mixed mode)
thetaphi at serv1:~$

I also fails without tiered compilation. It just takes longer (maybe because of statistics are different). I was not able to make 64 bit JVM fail, on 32 bit it's very easy if you run the full Lucene test suite and give the right command line options for the JVM:
- It does not fail with 64 bits (I tried like 20 runs of test suite, no success).
- It does not fail with 32 bits and "-client" (I also tried 20 runs, no success).
- It fails ASAP on 32 bits (in the first few Lucene tests with messages about random NPEs or failed assertions) with: "-server -Xbatch -XX:+TieredCompilation"
- It also fails on 32 bits, but takes longer (like 60 tests of the suite ran): "-server -Xbatch -XX:+TieredCompilation"
- Because it was not possible to reproducible on another machine (running Windows), which does not have AVX2 instruction set, so I tried to disable AVX(2) on 32 bits, but it still fails tests: "-server -Xbatch -XX:UseAVX=0" / "-server -Xbatch -XX:-UseSuperWord"

I will open a bug report with Rory and Balchandra giving the steps how to make the Lucene tests fail. We may help with trying stuff out, but we have no clue what's wrong. Especially every test run fails at a different place with various NPEs or test assertions failed.

The problems started around build 68.


Uwe Schindler
uschindler at 
ASF Member, Apache Lucene PMC / Committer
Bremen, Germany

> -----Original Message-----
> From: Dawid Weiss [mailto:dawid.weiss at]
> Sent: Tuesday, August 25, 2015 12:06 PM
> To: hotspot compiler
> Cc: Uwe Schindler; Balchandra Vaidya
> Subject: Re: NPE on tiered compilation only (seeking help to narrow it down)
> > 1. it happens on 32 bit and 64 bit JVMs (32 bit is easier to
> > reproduce),
> Correction: so far we can only reproduce it on the 32-bit build. Uwe has been
> trying to fail on 64 bit.
> Dawid

More information about the hotspot-compiler-dev mailing list