vitalyd at gmail.com
Tue Nov 24 14:13:40 UTC 2015
Yes, I "stole" that name from .NET but it's a great, short and very
accurate name. .NET goes a bit further by having a (static) GC class to
house this method (amongst other GC related ones), but for java Reference
(or whatever else) is good enough.
On Tue, Nov 24, 2015 at 9:09 AM, Andrew Haley <aph at redhat.com> wrote:
> On 11/24/2015 01:07 PM, Vitaly Davidovich wrote:
> > How about keepAlive? Reference.keepAlive(Object) reads better, IMO.
> It does indeed. Imperative names for methods almost always read better,
> IMO. And although we probably don't don't much care about C#, it too
> uses the name KeepAlive() for this.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the hotspot-compiler-dev