RFR(L): 8161259: Simplify including platform files.

Andrew Haley aph at redhat.com
Thu Jul 14 09:53:45 UTC 2016


On 14/07/16 10:17, Lindenmaier, Goetz wrote:

>> Are we really happy with
>>   40 #define SUB(x) x
>> SUB is a very generic name, and this is some very weird macro hacking.
>> At least we need an explanation in a comment.
> That's a good point, I'll rename it to HSSUB (hotspot submacro).
> It should not be too long because it's used so often on one line.

How about

 480 #  define xos_cpu_header(x, y)  XSTR(SUB(x)SUB(_)SUB(INCLUDE_SUFFIX_OS)SUB(_sparc)SUB(y))


 480 #  define xos_cpu_header(x, y)  XSTR(CONCAT(x,_)CONCAT(INCLUDE_SUFFIX_OS,CONCAT(_sparc,y)))

or maybe even

 480 #  define xos_cpu_header(x, y)  CONCAT5(x,_,INCLUDE_SUFFIX_OS,_sparc,y)

I would have understood immediately what that was doing.


More information about the hotspot-compiler-dev mailing list