<div dir="ltr"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><span style="font-size:12.8px">The choice of reachabilityFence was in part motivated by hearing<br></span><span style="font-size:12.8px">about mistakes in using C# keepAlive where people would place keepAlive<br></span><span style="font-size:12.8px">before uses of fields, rather than after them. A more accurate name<br></span><span style="font-size:12.8px">should reduce this error in Java.</span></blockquote><div><br></div><div>I don't see how reachabilityFence would help prevent that type of mistake/usage.  Having used KeepAlive in .NET, I personally think it's a better and more appropriate name and has the "demarcation" aspect (i.e. "keep this alive until the point where I wrote KeepAlive").  But, it's a bikeshed so I won't get hung up on it.</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Nov 24, 2015 at 12:06 PM, Doug Lea <span dir="ltr"><<a href="mailto:dl@cs.oswego.edu" target="_blank">dl@cs.oswego.edu</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On 11/24/2015 09:09 AM, Andrew Haley wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Bikeshedding,<br>
<br>
On 11/24/2015 01:07 PM, Vitaly Davidovich wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
How about keepAlive? Reference.keepAlive(Object) reads better, IMO.<br>
</blockquote>
<br>
It does indeed.  Imperative names for methods almost always read better,<br>
IMO.  And although we probably don't don't much care about C#, it too<br>
uses the name KeepAlive() for this.<br>
</blockquote>
<br></span>
Well, it is not an imperative notion, it is a demarcation.<br>
More like a semicolon than an action. (Which is the realm of fences.)<br>
<br>
The choice of reachabilityFence was in part motivated by hearing<br>
about mistakes in using C# keepAlive where people would place keepAlive<br>
before uses of fields, rather than after them. A more accurate name<br>
should reduce this error in Java.<span class="HOEnZb"><font color="#888888"><br>
<br>
-Doug<br>
<br>
<br>
</font></span></blockquote></div><br></div>