<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    I get this without --module-path:<br>
    <br>
      Fatal Error: Unable to find package java.lang in classpath or
    bootclasspath<br>
    <br>
    I guess before, when it was using the unnamed module, that it was
    picking up these<br>
    system classes from the jdk10 bootjdk, which doesn't seem ideal.<br>
    <br>
    It works without --upgrade-module-path, so I can remove that.<br>
    <br>
    dl<br>
    <br>
    <div class="moz-cite-prefix">On 11/7/18 8:12 PM, Mandy Chung wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:044203b5-a756-a0eb-057c-45f7fa0c93cf@oracle.com">
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
      Hi Dean,<br>
      <br>
      <div class="moz-cite-prefix">On 11/7/18 7:56 PM, <a
          class="moz-txt-link-abbreviated"
          href="mailto:dean.long@oracle.com" moz-do-not-send="true">dean.long@oracle.com</a>
        wrote:<br>
      </div>
      <blockquote type="cite"
        cite="mid:7ae7f7d9-b9f5-5560-1506-b6cab6286a86@oracle.com"><a
          class="moz-txt-link-freetext"
          href="https://bugs.openjdk.java.net/browse/JDK-8213348"
          moz-do-not-send="true">https://bugs.openjdk.java.net/browse/JDK-8213348</a>
        <br>
        <a class="moz-txt-link-freetext"
          href="https://bugs.openjdk.java.net/browse/JDK-8211781"
          moz-do-not-send="true">https://bugs.openjdk.java.net/browse/JDK-8211781</a>
        <br>
        <a class="moz-txt-link-freetext"
          href="http://cr.openjdk.java.net/%7Edlong/8213348/webrev/"
          moz-do-not-send="true">http://cr.openjdk.java.net/~dlong/8213348/webrev/</a>
        <br>
        <br>
      </blockquote>
      <pre><span class="new"> 108             --module-path $(JDK_OUTPUTDIR)/modules \</span>
 109             --upgrade-module-path $(JDK_OUTPUTDIR)/modules --system none \

You added `--module-path` option to javac.  What error did you
get without it?  It looks a bit suspicious.  I wonder if 
the `--upgrade-module-path` is needed as --system none is set.

We need Jon to advice on this javac command.

Mandy
</pre>
    </blockquote>
    <br>
  </body>
</html>