Re: OpenJDK 6 self test fails: java.lang.NoClassDefFoundError: Queens

Jeff Sinclair jeff at
Thu Apr 15 09:25:48 PDT 2010

Hi Christian,

Yup, if I run test_gamma I get that error. The Queens class is fine since I can run it with hotspot 1.6.0_18 without any issue.

I was aware about the potential for path lengths causing an issue but I could run the open jdk 7 build which is at the same directory level.

I have tried putting the distribution in /var/tmp/1.6.0.b18 but run into the same issue, so I am inclined to think it is not a path limit issue.

----- Reply message -----
From: "Christian Thalinger" <Christian.Thalinger at Sun.COM>
Date: Thu, Apr 15, 2010 09:27
Subject: OpenJDK 6 self test fails: java.lang.NoClassDefFoundError: Queens
To: <jeff at>
Cc: <hotspot-dev at>

On Wed, 2010-04-14 at 21:08 +0100, Jeff Sinclair wrote:
> Exception in thread "main" java.lang.NoClassDefFoundError: Queens
>         at java.lang.ClassLoader.findBootstrapClass(Native Method)
>         at
> java.lang.ClassLoader.findBootstrapClassOrNull(
>         at java.lang.ClassLoader.loadClass(
>         at java.lang.ClassLoader.loadClass(
>         at sun.misc.Launcher$AppClassLoader.loadClass(
>         at java.lang.ClassLoader.loadClass(
>         at java.lang.ClassLoader.loadClassInternal(
> Are there any known problems for the above 2 issues? I'm struggling to
> debug this at the moment and was wondering what information I could
> provide to help
> debug.

Hmm.  So when you go into the HotSpot build directory there is a
Queens.class and running ./test_gamma results in the above error?

In the past I got similar errors when I moved my HotSpot source
directory somewhere else and the paths didn't fit anymore (e.g. for
compiling Queens.class).

-- Christian

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the hotspot-dev mailing list