My OpenJDK 64-Bit Server VM crashes, what am I doing wrong?

Vladimir Kozlov vladimir.kozlov at
Fri Oct 29 15:17:28 PDT 2010


try to switch off compressed oops: -XX:-UseCompressedOops.

For implicit compressed NULL pointer check (as in this case) VM expects to get
SIGSEGV when loading from protected page below java heap instead of SIGBUS.
Could be the page was not reserved (there was bug 6947341 in VM fixed in
19.0-b04, so you should have the fix). Or OS throws SIGBUS instead of SIGSEGV
for some reasons. Note, address is aligned:

si_addr=4387303432 (0x10580F008)

Build fastdebug JVM and run it to get more information.


Ralph Seichter wrote:
> Hello list,
> I wrote about a JVM crash in the bsd-port-dev mailing list, and Kurt
> Miller suggested that I rather post here.
> Based on I have built
> OpenJDK on Mac OS X 10.6.4 Snow Leopard with the latest Xcode.
>   $ java -version
>   openjdk version "1.7.0-internal"
>   OpenJDK Runtime Environment (build 1.7.0-internal-ralph_2010_10_22_20_59-b00)
>   OpenJDK 64-Bit Server VM (build 19.0-b05, mixed mode)
> When I run a vanilla Tomcat 6.0.29 within Eclipse with this JVM, Tomcat
> seems to be OK. However, when I run Tomcat standalone with JAVA_HOME and
> JRE_HOME set to my OpenJDK build, Tomcat crashes whenever I try to
> access the Tomcat manager application (please see attached log).
> Maybe there is something wrong with my OpenJDK build, but how can I
> verify this?
> -Ralph

More information about the hotspot-dev mailing list