Request for review (S): 6817525: turn on method handle functionality by default for JSR 292

Vladimir Kozlov vladimir.kozlov at
Tue Mar 29 08:58:39 PDT 2011

I would prefer the old EnableInvokeDynamic which is more informative I think. 
Otherwise looks good.


Christian Thalinger wrote:
> On Mar 28, 2011, at 11:14 PM, John Rose wrote:
>> On Mar 28, 2011, at 12:58 PM, Tom Rodriguez wrote:
>>> Why do we need the related switches as separate flags at all?  EnableInvokeDynamic is required for 7 and the others are all implied by EnableInvokeDynamic.  I don't see how they can be turned on or off independently in a meaningful way.  I think it's more confusing having all these separate subflags.
>> Merging them up to a single flag would be OK with me.  (And since it's diagnostic, I don't care too much what the name is.)
> The obvious name is EnableJSR292.  The change is now much bigger but almost all changes are trivial renames:
> I did a lot of testing with JRuby tests today and except a couple of (expected) hiccups it looks good.
> -- Christian

More information about the hotspot-dev mailing list