RFR: 8068396: Rename assert() to vmassert()
kim.barrett at oracle.com
Wed Dec 31 02:44:33 UTC 2014
On Dec 30, 2014, at 8:22 PM, David Holmes <david.holmes at oracle.com> wrote:
>> * Simplified the definition of vmassert_status to just use vmassert,
> But by doing that you are forcing evaluation of err_msg and strerror in all cases, rather than only when the assertion condition is false.
vmassert (nee assert) only evaluates the msg argument when the assertion condition is false. It’s a macro, after all.
More information about the hotspot-dev