RFR: 8035393: Use CLDClosure instead of CLDToOopClosure in frame::oops_interpreted_do
coleen.phillimore at oracle.com
Thu Feb 20 12:04:04 PST 2014
Looks good. CLDClosure is a shorter name too.
On 2/20/14 9:28 AM, Stefan Karlsson wrote:
> On 2014-02-20 12:35, Mikael Gerdin wrote:
>> On Thursday 20 February 2014 10.59.41 Stefan Karlsson wrote:
>>> Hi all,
>>> Please, review this patch to change the closure type used in
>>> frame::oops_interpreted_do from CLDToOopClosure to CLDClosure, which is
>>> an abstract base class of CLDToOopClosure.
>>> We need this for the G1 Class Unloading project, to be able to
>>> specialize the CLD scanning code during the Initial Mark phase.
>> Looks good.
> Thanks for the review.
More information about the hotspot-dev