RFR(S): 8046818: Hotspot build system looking for sdt.h in the wrong place

Lois Foltan lois.foltan at oracle.com
Thu Jul 3 19:26:52 UTC 2014

Looks ok to me as well.

On 7/3/2014 8:03 AM, David Holmes wrote:
> Looks ok.
> David
> On 3/07/2014 10:32 AM, Mikael Vidstedt wrote:
>> Please review the below fix.
>> When using a compiler which does not use the default "/" as system root
>> the system headers are not picked up from /usr/include. This means that
>> looking for sdt.h in /usr/include is not correct - even if the machine
>> in question has that header file available it may still fail at compile
>> time if the compiler doesn't have sdt.h in its system root.
>> gcc has a useful option (-print-sysroot) which prints the system root
>> being used. I have not found any equivalent option for clang, so this
>> fix will unfortunately not solve this problem when using clang. When we
>> rewrite the Hotspot build system to use the new top level build system
>> this can be solved in a better way.
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8046818
>> Webrev:
>> http://cr.openjdk.java.net/~mikael/webrevs/8046818/webrev.00/webrev/
>> Cheers,
>> Mikael

More information about the hotspot-dev mailing list