RFR(S): 8059137: MemoryPoolMXBeans for different code heaps should contain 'Code heap' in their names
filipp.zhinkin at oracle.com
Mon Sep 29 19:23:20 UTC 2014
yes, I'm fine with that.
Previously there was a single 'code cache'
and now it is divided into several code heaps,
so naming convention used for memory pools looks pretty natural.
On 29.09.2014 21:03, Vladimir Kozlov wrote:
> Are you okay with this?
> The name will be 'Code Cache' in non-segmented case (as before
> segmented code cache implementation).
> But the name for segmented case will star with 'Code Heap'. See
> examples in RFR.
> Should both cases have the same name? I am asking you since you filed
> the RFE.
> On 9/29/14 4:56 AM, Filipp Zhinkin wrote:
>> Hi Tobias,
>> thank you for taking care of it. The change looks good.
>> On 09/29/2014 02:08 PM, Tobias Hartmann wrote:
>>> please review the following patch.
>>> Bug: https://bugs.openjdk.java.net/browse/JDK-8059137
>>> Webrev: http://cr.openjdk.java.net/~thartmann/8059137/webrev.00/
>>> == Problem ==
>>> The segmented code cache implementation registers a memory pool for
>>> each code heap. To be consistent with the
>>> "non-segmented" output, the names of these pools should contain the
>>> word "code heap".
>>> == Solution ==
>>> I added "Code Heap" to the name of the segments. The output now
>>> looks like this:
>>> $ /export/bin/java -XX:-SegmentedCodeCache Test
>>> Code Cache
>>> $ /export/bin/java -XX:+SegmentedCodeCache Test
>>> Code Heap 'non-methods'
>>> Code Heap 'profiled nmethods'
>>> Code Heap 'non-profiled nmethods'
More information about the hotspot-dev