RFR: 8073387: Move VerifyOopClosures out from genOopClosures.hpp
coleen.phillimore at oracle.com
Wed Feb 18 13:17:03 UTC 2015
I have a request - can you name the file verifyOopClosure.hpp There's a
different JVM option that we use that is -XX:+VerifyOops which is
completely different than this. The name of the class in verifyOop.hpp
is VerifyOopClosure also.
On 2/18/15, 3:25 AM, Mikael Gerdin wrote:
> Hi Stefan,
> On 2015-02-18 09:10, Stefan Karlsson wrote:
>> Please review this patch to move VerifyOopClosures out from
>> genOopClosures.hpp. This way users of VerifyOopClosures don't have to
>> include genOopClosures.hpp anymore. The implementation of
>> VerifyOopClosures::do_oop_work is placed in oop.cpp, where the other
>> VerifyOopClosure functions are located.
> Looks good to me.
More information about the hotspot-dev