RFR: 8068396: Rename assert() to vmassert()

Kim Barrett kim.barrett at oracle.com
Mon Jan 12 20:31:52 UTC 2015

On Jan 12, 2015, at 4:20 AM, Erik Helin <erik.helin at oracle.com> wrote:
> On 2015-01-09, Kim Barrett wrote:
>> On Jan 8, 2015, at 8:05 PM, Kim Barrett <kim.barrett at oracle.com> wrote:
>>> On Jan 8, 2015, at 7:43 PM, Coleen Phillimore <coleen.phillimore at oracle.com> wrote:
>>>> My prior email asked if you could test this change by changing an assert to vmassert.  The assert in debug.cpp test_error_handler to vmassert would be a good one to test this change.
>>> Ah, now I understand what you were asking for.  OK, I’ll do that and post a new webrev later this evening.
>> New webrev: http://cr.openjdk.java.net/~kbarrett/8068396/webrev.03/
>> Incremental webrev: http://cr.openjdk.java.net/~kbarrett/8068396/webrev.03.incr/
> Looks good, Reviewed.

Erik - thanks for your review.

More information about the hotspot-dev mailing list