RFR: 8080746: Refactor oop iteration macros to be more general
stefan.johansson at oracle.com
Wed May 20 08:58:02 UTC 2015
Please review this change to generalize the oop iteration macros:
The macros for the oop_oop_iterate functions were defined for all *Klass
types even though they were very similar. This change extracts and
generalizes the macros to klass.hpp and arrayKlass.hpp.
For the arrays the *_OOP_OOP_ITERATE_BACKWARDS_* macros is now called
OOP_OOP_ITERATE_NO_BACKWARDS_* to reflect that for arrays we currently
don't have a reverse implementation.
More information about the hotspot-dev