RFR: 8077571: ObjPtrQueue is poorly named
christian.thalinger at oracle.com
Fri Nov 6 22:21:38 UTC 2015
> On Nov 6, 2015, at 12:09 PM, Kim Barrett <kim.barrett at oracle.com> wrote:
> [Sending to hotspot-dev because this touches runtime and compiler
> files too. I'm particularly looking for a compiler person for the
> change to HotSpotVMConfig.java.]
Yes, that change looks good.
> Please review this rename of ObjPtrQueue to SATBMarkQueue. This
> cleanup is being done in preparation for some further changes that
> will make the name more widely used.
> Probably the satbQueue.[ch]pp files should be renamed to
> satbMarkQueue.[ch]pp. I've not made such a change because my
> understanding is that mercurial mq doesn't really understand file
More information about the hotspot-dev