RFR: 8077571: ObjPtrQueue is poorly named

Bengt Rutisson bengt.rutisson at oracle.com
Sun Nov 8 12:23:25 UTC 2015

Hi Kim,

On 2015-11-06 23:09, Kim Barrett wrote:
> [Sending to hotspot-dev because this touches runtime and compiler
> files too. I'm particularly looking for a compiler person for the
> change to HotSpotVMConfig.java.]
> Please review this rename of ObjPtrQueue to SATBMarkQueue.  This
> cleanup is being done in preparation for some further changes that
> will make the name more widely used.
> Probably the satbQueue.[ch]pp files should be renamed to
> satbMarkQueue.[ch]pp.  I've not made such a change because my
> understanding is that mercurial mq doesn't really understand file
> renames.

I think you should rename the files too. Mercurial handles the history 
over renames, but you sometimes have to explicitly tell it to follow the 

You can try this with all the GC files that were renamed as part of the 
directory restructure in May. See for example:

$ hg log  src/share/vm/gc/g1/g1CollectedHeap.cpp  | wc
     381    1434   12851

$ hg log -f src/share/vm/gc/g1/g1CollectedHeap.cpp  | wc
    2611   10085   88115

> CR:
> https://bugs.openjdk.java.net/browse/JDK-8077571
> Webrev:
> http://cr.openjdk.java.net/~kbarrett/8077571/webrev.00/

Except for the renaming of the files I think it looks good. I don't need 
to see an updated webrev for the file rename.



> Testing:

More information about the hotspot-dev mailing list