RFR: 8077571: ObjPtrQueue is poorly named

Thomas Schatzl thomas.schatzl at oracle.com
Mon Nov 9 09:39:15 UTC 2015


On Fri, 2015-11-06 at 17:09 -0500, Kim Barrett wrote:
> [Sending to hotspot-dev because this touches runtime and compiler
> files too. I'm particularly looking for a compiler person for the
> change to HotSpotVMConfig.java.]
> Please review this rename of ObjPtrQueue to SATBMarkQueue.  This
> cleanup is being done in preparation for some further changes that
> will make the name more widely used.
> Probably the satbQueue.[ch]pp files should be renamed to
> satbMarkQueue.[ch]pp.  I've not made such a change because my
> understanding is that mercurial mq doesn't really understand file
> renames.
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8077571
> Webrev:
> http://cr.openjdk.java.net/~kbarrett/8077571/webrev.00/
> Testing:

  looks good to me. Just rename the files, mercurial understands


More information about the hotspot-dev mailing list