RFR 8134995(M): [REDO] GC: implement ranges (optionally constraints) for those flags that have them missing

sangheon.kim sangheon.kim at oracle.com
Fri Sep 25 17:42:16 UTC 2015

Hi Kim, Jon and Zoltan,

Here's next version of webrev.
This includes:
- changed from '4' to 'wordSize' at g1_globals.hpp. (Kim and Jon? )
- removed test code which is already commented out at 
TestG1HeapRegionSize.java. (Zoltan)



On 09/24/2015 10:39 AM, Kim Barrett wrote:
> On Sep 23, 2015, at 7:57 PM, sangheon.kim <sangheon.kim at oracle.com> wrote:
>>> I see now.  jintSize would be better than 4.  But I think even better would be pointer size,
>>> though I haven’t found an existing constant for that.  Maybe sizeof(address)?
>> We have 'const int wordSize = sizeof(char*)'.
>>> The only
>>> disadvantage to that is the max value is then smaller on 64bit platforms than on 32bit
>>> platforms.  I doubt the difference is interesting in practice though.
>> I agree that there's no big difference in practice.
>> I just wanted to avoid to have smaller upper limit for 64bit platforms.
>> But if you prefer to use 'wordSize' instead of '4', I'm fine. It would give better readability.
> Yes, please.

More information about the hotspot-dev mailing list