tobias.hartmann at oracle.com
Mon Mar 14 08:28:52 UTC 2016
On 13.03.2016 23:08, kirk.pepperdine at gmail.com wrote:
> I’ve just been visiting the work done on the code cache and I’ve noticed that the pool names have been changed from CodeCache to CodeHeap. Is there any reason for the change to the naming convention?
> Also, the DiagnosticCommand seems to refer to the compilerCodeCache as well as MemoryManager.CodeCacheManager which would seem inconsistent with this change.
With the Segmented Code Cache JEP , the code cache consists of multiple smaller segments (CodeHeaps) instead of one large segment. If segmentation is enabled (controlled by -XX:SegmentedCodeCache) we now have multiple pools corresponding to these individual code heaps.
More information about the hotspot-dev