RFR 8155794 Move Objects.checkIndex BiFunction accepting methods to an internal package
paul.sandoz at oracle.com
Tue May 3 20:03:12 UTC 2016
> On 3 May 2016, at 07:05, Remi Forax <forax at univ-mlv.fr> wrote:
> Looks good to me.
> minor nitpick, neither checkFromToIndex() nor checkFromIndexSize() are instrinsic (now !) but i think they also should be annotated with @ForceInline in j.u.Objects to avoid the code to be asymmetric or weird if one of these methods is intrinsinfied later.
I was tempted, but for the moment i am inclined to leave as is and revisit if/when necessary. Trying to be conservative when using those annotations.
More information about the hotspot-dev