RFR 8147039 : Incorrect locals and operands in compiled frames

Mandy Chung mandy.chung at oracle.com
Wed May 4 00:24:35 UTC 2016

> On May 3, 2016, at 4:43 PM, Brent Christian <brent.christian at oracle.com> wrote:
> Hi, Mandy
>> On 05/03/2016 01:45 PM, Mandy Chung wrote:
>> One minor nit: in stackwalk.cpp, the local variable “anchor” used in
>> a couple places should also be renamed.  You can fix that up before
>> you push (no need for a new webrev)
> Ah, looks like I missed JavaFrameStream::from_current().
> Are you okay with _anchor as a field name in JavaFrameStream, or would you prefer, say, "_magic"?

_anchor as a field name is fine as that also serves as the purpose.


> Thanks for having a look.
> -Brent

More information about the hotspot-dev mailing list