RFR: 8186166: Generalize Atomic::cmpxchg with templates
kim.barrett at oracle.com
Tue Aug 22 02:17:22 UTC 2017
> On Aug 21, 2017, at 9:28 PM, David Holmes <david.holmes at oracle.com> wrote:
> On 19/08/2017 4:45 AM, Kim Barrett wrote:
>> Rename IntegerTypes to PrimitiveConversions. This is the change I
>> said I was going to leave until the end. Looks like I could have done
>> it earlier; webrev did a fine job with the moved file.
>> full: http://cr.openjdk.java.net/~kbarrett/8186166/hotspot.03/
>> incr: http://cr.openjdk.java.net/~kbarrett/8186166/hotspot.03.inc/
> Looks okay justAPityItisSuchALongname :)
It’s not so often for that to bother me. And I’m used to some of the GC class names.
>> linux_aarch fix, rename test_integerTypes.cpp to test_primitiveConversions.cpp.
>> full: http://cr.openjdk.java.net/~kbarrett/8186166/hotspot.04/
>> incr: http://cr.openjdk.java.net/~kbarrett/8186166/hotspot.04.inc/
>> I'm hoping hotspot.04 will be the final version that I'll be handing
>> off to Erik, as he returns from vacation and I start mine.
>> I'm working on a change in a similar style for Atomic::add, and hope
>> to send out an RFR later today. I'll be handing that off to Erik as
> No further comments on this from me.
More information about the hotspot-dev