RFR(10)(XS): JDK-8171365: nsk/jvmti/scenarios/events/EM04/em04t001: many errors for missed events

dean.long at oracle.com dean.long at oracle.com
Wed Jun 7 22:20:40 UTC 2017

Sorry for the late review, but I think that anything called blobs_do 
should use FOR_ALL_HEAPS, and if we want to restrict to just 
FOR_ALL_NMETHOD_HEAPS then that should be called nmethod_blobs_do.  We 
are just getting lucky that all the GC uses are only interested in 
nmethods.  If all uses turn out to be interested in nmetods only, then 
only a rename from blobs_do to nmethods_blobs_do is needed.


On 6/7/17 12:49 AM, Tobias Hartmann wrote:
> Hi,
> On 07.06.2017 00:35, serguei.spitsyn at oracle.com wrote:
>> I agree.
>> Just wanted to highlight the regressed patch might have more issues.
>> So, the Compiler team needs to double-check it.
> I quickly checked all cases and they look okay to me. Will double check with the team though.
> Best regards,
> Tobias

More information about the hotspot-dev mailing list