RFR (S) 8182848: Some functions misplaced in debug.hpp

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Wed Jun 28 15:38:10 UTC 2017

Summary: moved to vmError.hpp,cpp where they seemed more appropriate

Moved the function pd_ps() into frame_sparc.cpp eliminating 
debug_cpu.cpp files.   You can pick a better name for this if you want.

open webrev at http://cr.openjdk.java.net/~coleenp/8182848.01/webrev
bug link https://bugs.openjdk.java.net/browse/JDK-8182848

Tested with JPRT.


More information about the hotspot-dev mailing list