RFR (S) 8182848: Some functions misplaced in debug.hpp

Kim Barrett kim.barrett at oracle.com
Thu Jun 29 00:54:09 UTC 2017

> On Jun 28, 2017, at 11:38 AM, coleen.phillimore at oracle.com wrote:
> Summary: moved to vmError.hpp,cpp where they seemed more appropriate
> Moved the function pd_ps() into frame_sparc.cpp eliminating debug_cpu.cpp files.   You can pick a better name for this if you want.
> open webrev at http://cr.openjdk.java.net/~coleenp/8182848.01/webrev
> bug link https://bugs.openjdk.java.net/browse/JDK-8182848
> Tested with JPRT.
> Thanks,
> Coleen

I didn’t notice anything other than minor things that Stefan or Thomas have already commented on.

Looks good to me.

More information about the hotspot-dev mailing list