RFR (S): 8214850: Rename vm_operations* to vmOperations*

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Wed Dec 5 14:27:22 UTC 2018

This change looks good to me.  I type this name wrong every time.

On 12/5/18 6:08 AM, David Holmes wrote:
> Hi Thomas,
> On 5/12/2018 8:47 pm, Thomas Schatzl wrote:
>> Hi all,
>>    can I have reviews for this change that renames the vm_operations
>> files to vmOperations?
>> This has been requested in the JDK-8214791 review but I did not want to
>> merge these.
>> CR:
>> https://bugs.openjdk.java.net/browse/JDK-8214850
>> Webrev:
>> http://cr.openjdk.java.net/~tschatzl/8214850/webrev/
>> Testing:
>> build on all (Oracle) platforms
> I'm not a fan of gratuitous renames as it makes it harder to query the 
> history of a file.

hg mv will keep the history of the file moved.

> But this seems to be an accurate renaming so in that sense this is 
> Reviewed.
> But if we're going to impose a particular naming scheme perhaps we 
> should bite the bullet and bring everything into line? arguments_ext, 
> os_ext, os_perf, vm_version ...

Yes, eventually, depending on distracting the misnaming is, and how 
difficult to find the file.  vm_version seems like a candidate.

> Cheers,
> David
>> Thanks,
>>    Thomas

More information about the hotspot-dev mailing list