RFR (S): 8214850: Rename vm_operations* to vmOperations*

David Holmes david.holmes at oracle.com
Wed Dec 5 21:51:24 UTC 2018

On 6/12/2018 12:27 am, coleen.phillimore at oracle.com wrote:
> This change looks good to me.  I type this name wrong every time.
> On 12/5/18 6:08 AM, David Holmes wrote:
>> Hi Thomas,
>> On 5/12/2018 8:47 pm, Thomas Schatzl wrote:
>>> Hi all,
>>>    can I have reviews for this change that renames the vm_operations
>>> files to vmOperations?
>>> This has been requested in the JDK-8214791 review but I did not want to
>>> merge these.
>>> CR:
>>> https://bugs.openjdk.java.net/browse/JDK-8214850
>>> Webrev:
>>> http://cr.openjdk.java.net/~tschatzl/8214850/webrev/
>>> Testing:
>>> build on all (Oracle) platforms
>> I'm not a fan of gratuitous renames as it makes it harder to query the 
>> history of a file.
> hg mv will keep the history of the file moved.

Yes but you have to tell hg to follow across the rename; and graphical 
tools like TortoiseHg don't seem to follow; and if you only know the old 
name of the file (eg from before the module system) I have yet to 
determine how to get hg or Tortoise to show it to me. <sigh>


>> But this seems to be an accurate renaming so in that sense this is 
>> Reviewed.
>> But if we're going to impose a particular naming scheme perhaps we 
>> should bite the bullet and bring everything into line? arguments_ext, 
>> os_ext, os_perf, vm_version ...
> Yes, eventually, depending on distracting the misnaming is, and how 
> difficult to find the file.  vm_version seems like a candidate.
> thanks,
> Coleen
>> Cheers,
>> David
>>> Thanks,
>>>    Thomas

More information about the hotspot-dev mailing list