RFR: 8215492: Rename INTERNAL_EMPTY to something less "internal"
per.liden at oracle.com
Mon Dec 17 18:02:10 UTC 2018
The INTERNAL_EMPTY macro is sometimes useful outside of access*.[ch]pp.
We should change the name of that macro and allow it to be used, for
example, in JNIHandle code, which today passes a "0".
I propose that we change it to DECORATORS_NONE, but I'm open to other
This patch also adjusts the JNI Handle code to make use of this macros
instead of using "0".
(Note! This patch is based on JDK-8215451, which has not yet propagated
from jdk/jdk12 to jdk/jdk)
More information about the hotspot-dev