RFR: 8215492: Rename INTERNAL_EMPTY to something less "internal"

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Mon Dec 17 18:16:48 UTC 2018

I like this a lot better than 0.


On 12/17/18 1:02 PM, Per Liden wrote:
> The INTERNAL_EMPTY macro is sometimes useful outside of 
> access*.[ch]pp. We should change the name of that macro and allow it 
> to be used, for example, in JNIHandle code, which today passes a "0".
> I propose that we change it to DECORATORS_NONE, but I'm open to other 
> suggestions.
> This patch also adjusts the JNI Handle code to make use of this macros 
> instead of using "0".
> Bug: https://bugs.openjdk.java.net/browse/JDK-8215492
> Webrev: http://cr.openjdk.java.net/~pliden/8215492/webrev.0
> (Note! This patch is based on JDK-8215451, which has not yet 
> propagated from jdk/jdk12 to jdk/jdk)
> /Per

More information about the hotspot-dev mailing list