RFR: 8204834: Fix confusing "allocate" naming in OopStorage
thomas.schatzl at oracle.com
Mon Jul 9 08:47:58 UTC 2018
On Sun, 2018-07-08 at 12:00 -0400, Kim Barrett wrote:
> Please review this nomenclature change in the implementation of
> OopStorage. This is a followup to JDK-8204097; in the review of that
> change Coleen noted that some names were confusing, especially
> "allocate_list()", which is an accessor and doesn't allocate
> This is a mostly mechanical change:
> There are a few non-mechanical changes in comments, to make the
> comments consistently use the same names as the code. For example,
> some underscores were added when referring to members in comments.
> Also fixed a few related typos.
looks good to me.
More information about the hotspot-dev