RFR: 8204097: Simplify OopStorage::AllocateList block entry access

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Fri Jun 1 13:13:17 UTC 2018

Hi Kim,   This change looks fine, except these names caused me a lot of 


+ block.allocate_entry()._next = old;
+ old->allocate_entry()._prev = █

This allocate_entry() call doesn't actually allocate anything but get 
the allocation list entry.   Can these things be renamed in a subsequent 


On 5/30/18 4:19 PM, Kim Barrett wrote:
> Please review this simplification of OopStorage::AllocateList,
> removing the no longer used support for blocks being in multiple lists
> simultaneously. There is now only one list of blocks, the
> _allocate_list.
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8204097
> Webrev:
> http://cr.openjdk.java.net/~kbarrett/8204097/open.00/
> Testing:
> Mach5 tier{1,2,3}

More information about the hotspot-dev mailing list