RFR: 8204585: Remove IN_ARCHIVE_ROOT from Access API

Kim Barrett kim.barrett at oracle.com
Mon Jun 11 22:58:57 UTC 2018

> On Jun 11, 2018, at 6:26 PM, Jiangli Zhou <jiangli.zhou at oracle.com> wrote:
> Hi Kim,
> Both the changes and testing look good to me. Would it be better to rename MetaspaceShared::unarchive_heap_object() to MetaspaceShared::materialize_archived_object() to reflect the API in G1CollectedHeap? The use of ‘materialize’ in the GC API looks very good. Thank you for continuing improving the GC underlying support!

I like that suggestion.  I’ll see what other folks think, but I’m inclined to do it.

More information about the hotspot-dev mailing list