RFR: 8199604: Rename CardTableModRefBS to CardTableBarrierSet

Erik Osterlund erik.osterlund at oracle.com
Sat Mar 17 08:28:16 UTC 2018

Hi Per,

Thanks for the review!


> On 17 Mar 2018, at 00:34, Per Liden <per.liden at oracle.com> wrote:
> Looks good!
> /Per
>> On 03/16/2018 01:17 PM, Erik Österlund wrote:
>> Hi,
>> After collapsing barrier sets, it seems like CardTableModRefBS is the only barrier set that encodes "ModRef" in its name and uses the "BS" suffix instead of spelling out "BarrierSet".
>> This is a weird inconsistency that I have solved by renaming CardTableModRefBS to CardTableBarrierSet.
>> Files were renamed like this:
>> parCardTableModRefBS.cpp => cmsCardTable.cpp (this file contains a bunch of implementations for the card table used by CMS and is in the CMS directory)
>> cardTableModRefBS.cpp => cardTableBarrierSet.cpp
>> cardTableModRefBS.hpp => cardTableBarrierSet.hpp
>> cardTableModRefBS.inline.hpp => cardTableBarrierSet.inline.hpp
>> I have performed an automatic search and replace to rename CardTableModRefBS to CardTableBarrierSet, and manually clicked through everything to make sure that space alignment, comments, etc all look as they should. I have also checked that the SA agent is not affected and run hs-tier1 on this changeset.
>> Despite the fix being a bit lengthy, I would still prefer to consider it trivial (unless somebody opposes that) as I am only renaming a class in a rather mechanical way. Hope we can agree about that.
>> Webrev:
>> http://cr.openjdk.java.net/~eosterlund/8199604/webrev.00/
>> Bug:
>> https://bugs.openjdk.java.net/browse/JDK-8199604
>> Testing:
>> mach5 hs-tier1-3
>> Thanks,
>> /Erik

More information about the hotspot-dev mailing list