RFR(s): 8211403: Rename SafepointMechanism::poll(...)

Robbin Ehn robbin.ehn at oracle.com
Wed Nov 7 08:32:36 UTC 2018

Hi all, please review.

We rename SafepointMechanism::poll to SafepointMechanism::should_block to make
it more clear what the method do.

CR: https://bugs.openjdk.java.net/browse/JDK-8211403
Webrev: http://cr.openjdk.java.net/~rehn/8211403/webrev/

Sanity on tier 1.

Thanks, Robbin

More information about the hotspot-dev mailing list