RFR(s): 8211403: Rename SafepointMechanism::poll(...)

David Holmes david.holmes at oracle.com
Wed Nov 7 09:32:08 UTC 2018

Hi Robbin,

On 7/11/2018 6:32 PM, Robbin Ehn wrote:
> Hi all, please review.
> We rename SafepointMechanism::poll to SafepointMechanism::should_block 
> to make it more clear what the method do.

Fair enough, but doesn't that just imply that global_poll and local_poll 
are also mis-named? How far should this rename go?


> CR: https://bugs.openjdk.java.net/browse/JDK-8211403
> Webrev: http://cr.openjdk.java.net/~rehn/8211403/webrev/
> Sanity on tier 1.
> Thanks, Robbin

More information about the hotspot-dev mailing list