RFR(s): 8211403: Rename SafepointMechanism::poll(...)
david.holmes at oracle.com
Wed Nov 7 11:03:33 UTC 2018
On 7/11/2018 8:04 PM, Robbin Ehn wrote:
> Hi David,
> On 2018-11-07 10:32, David Holmes wrote:
>> Hi Robbin,
>> On 7/11/2018 6:32 PM, Robbin Ehn wrote:
>>> Hi all, please review.
>>> We rename SafepointMechanism::poll to
>>> SafepointMechanism::should_block to make it more clear what the
>>> method do.
>> Fair enough, but doesn't that just imply that global_poll and
>> local_poll are also mis-named? How far should this rename go?
> I think they are fine, because of the different context. As I see it
> should_block is implemented by actively checking (polling) the threads
> page or the global state.
Except there's a level in between that. If poll() should be
should_block() then global_poll() should be global_should_block() and
local_poll() should be local_should_block(). I don't see any difference.
It's the methods under that that actually "poll" something.
> Thanks, Robbin
>>> CR: https://bugs.openjdk.java.net/browse/JDK-8211403
>>> Webrev: http://cr.openjdk.java.net/~rehn/8211403/webrev/
>>> Sanity on tier 1.
>>> Thanks, Robbin
More information about the hotspot-dev