RFR: 8234796: Refactor Handshake::execute to take a HandshakeOperation
robbin.ehn at oracle.com
Tue Nov 26 13:07:41 UTC 2019
Hi all, please review.
The handshake code needs more information about the handshake operation.
We change type from ThreadClosure to HandshakeOperation in Handshake::execute.
This enables us to add more details to the HandshakeOperation as needed going
Tested t1 and t1-3 together with the logging improvements in 8234742.
It was requested that "HandshakeOperation()" would take the name instead having
"virtual const char* name();". Which is in this patch.
More information about the hotspot-dev