RFR: 8234796: Refactor Handshake::execute to take a HandshakeOperation
robbin.ehn at oracle.com
Wed Nov 27 15:25:21 UTC 2019
Hi all, please review.
Here is the result after Per's suggestion:
(incremental made no sense)
Due to circular dependency between thread.hpp and handshake.hpp, I moved the
ThreadClosure to iterator.hpp, as was suggested offline.
On 11/26/19 2:07 PM, Robbin Ehn wrote:
> Hi all, please review.
> The handshake code needs more information about the handshake operation.
> We change type from ThreadClosure to HandshakeOperation in Handshake::execute.
> This enables us to add more details to the HandshakeOperation as needed going
> Tested t1 and t1-3 together with the logging improvements in 8234742.
> It was requested that "HandshakeOperation()" would take the name instead having
> "virtual const char* name();". Which is in this patch.
> Thanks, Robbin
More information about the hotspot-dev