RFR: 8234796: Refactor Handshake::execute to take a HandshakeOperation
david.holmes at oracle.com
Thu Nov 28 06:21:52 UTC 2019
On 28/11/2019 1:25 am, Robbin Ehn wrote:
> Hi all, please review.
> Here is the result after Per's suggestion:
> (incremental made no sense)
> Due to circular dependency between thread.hpp and handshake.hpp, I moved
> the ThreadClosure to iterator.hpp, as was suggested offline.
That all looks good to me! Thanks for splitting these up.
> Passes t1-3
> Thanks, Robbin
> On 11/26/19 2:07 PM, Robbin Ehn wrote:
>> Hi all, please review.
>> The handshake code needs more information about the handshake operation.
>> We change type from ThreadClosure to HandshakeOperation in
>> This enables us to add more details to the HandshakeOperation as
>> needed going forward.
>> Tested t1 and t1-3 together with the logging improvements in 8234742.
>> It was requested that "HandshakeOperation()" would take the name
>> instead having "virtual const char* name();". Which is in this patch.
>> Thanks, Robbin
More information about the hotspot-dev