Who hates the *Ratio parameters?
Paul.Hohensee at Sun.COM
Wed Aug 13 12:14:01 PDT 2008
I would. I'd use "SurvivorPercent" though, not "SurvivorPerc". The latter
sounds like a bonus you get for surviving. :)
Or maybe just add "SurvivorSize" and "MaxSurvivorSize", like we have
"NewSize" and "MaxNewSize". That'd be exact, unlike either a percent
or a ratio.
btw, we seem to use the term "Ratio" to mean both a genuine ratio _and_ a
percent. E.g., "SurvivorRatio" is a genuine ratio, but "MinHeapFreeRatio"
is a percent.
Tony Printezis wrote:
> Hi all,
> I personally don't like the *Ratio parameters (e.g.,
> -XX:SurvivorRatio=<N>) as I don't think they are very intuitive to set.
> I've heard the same from a few customers too. Would most people prefer
> parameters based on percentages (e.g., -XX:SurvivorPerc=<N>, where 0 <=
> <N> <= 100) instead?
hotspot-gc-use mailing list
hotspot-gc-use at openjdk.java.net
More information about the hotspot-gc-dev