for review (M): 6863023: need non-perm oops in code cache for JSR 292

John Rose John.Rose at Sun.COM
Wed Aug 5 16:53:16 PDT 2009


On Jul 31, 2009, at 9:58 AM, Vladimir Kozlov wrote:

> Could you rename non_perm_state_clean() to non_perm_not_marked()
> or something otherwise the next code looks strange since
> the non_perm_state is also used to flag "on list" state:
>
> +     debug_only(cur->clear_non_perm_marked());
> +     assert(cur->non_perm_state_clean(), "");
> +     assert(cur->on_non_perm_list(), "else shouldn't be on this  
> list");

Done.   Added a brief comment explaining the "not_" variation.
   +  // N.B. there is no positive marked query, and we only use the  
not_marked query for asserts.

> In nmethod.hpp could you move enum above its usage and use it in
> on_non_perm_list()?

Thanks; done.

> Can you change the comment in parse3.cpp to next?:
>
>    // cases:
>    //   should_be_constant = (oop == null || oop in perm space ||  
> NonPermCodeRefs >= 2)
>    //   has_encoding       = (should_be_constant || NonPermCodeRefs  
> == 1)
>    //

Yes, done.  (Except that I prefer NonPermCodeRefs >= 1 for the second  
equation.)

> In globals.hpp it would be better to have "1: allow" on a separate  
> line.

Fixed.

Thanks!

-- John



More information about the hotspot-gc-dev mailing list