hg: jdk7/hotspot-gc/hotspot: 6971296: G1: simplify G1RemSet class hierarchy

john.cuthbertson at oracle.com john.cuthbertson at oracle.com
Tue Oct 12 12:00:17 PDT 2010


Changeset: c32059ef4dc0
Author:    johnc
Date:      2010-10-12 09:36 -0700
URL:       http://hg.openjdk.java.net/jdk7/hotspot-gc/hotspot/rev/c32059ef4dc0

6971296: G1: simplify G1RemSet class hierarchy
Summary: Remove G1RemSet base class and StupidG1RemSet class; rename HRInto_G1RemSet to just G1RemSet.
Reviewed-by: ysr, tonyp

! src/share/vm/gc_implementation/g1/g1CollectedHeap.cpp
! src/share/vm/gc_implementation/g1/g1OopClosures.hpp
! src/share/vm/gc_implementation/g1/g1RemSet.cpp
! src/share/vm/gc_implementation/g1/g1RemSet.hpp
! src/share/vm/gc_implementation/g1/g1RemSet.inline.hpp
! src/share/vm/gc_implementation/g1/g1_globals.hpp
! src/share/vm/gc_implementation/includeDB_gc_g1



More information about the hotspot-gc-dev mailing list