CMS initial mark pauses

Adam Hawthorne adamh at basis.com
Thu Oct 14 11:31:23 PDT 2010


Hi all,

I'm seeing a customer running CMS with some fairly long initial mark pauses,
especially relative to all the other pauses.  The machine is (I believe) an
Itanium 6-way running HP-UX, with HP's version of Hotspot, version 1.6.0.06
.

What I'm seeing is that all the remark and young gc pauses are less than
500ms, and very consistent.  There are a lot of initial mark pauses that
also fall in this range.  That's our target, and things look really good.
 The problem is that there are occasional pauses of up to 1.5s, which is
unacceptable for the customer.  Does anyone have any ideas what can cause
(seemingly random) long initial mark pauses?

Here's an example of one of the long mark pauses:

45946.930: [GC [1 CMS-initial-mark: 957254K(1598236K)] 1473999K(2151196K),
1.3505680 secs] [Times: user=1.34 sys=0.00, real=1.35 secs]

Here's an example of one of the more typical pauses:

45954.362: [GC [1 CMS-initial-mark: 963824K(1598236K)] 1001370K(2151196K),
0.1579016 secs] [Times: user=0.16 sys=0.00, real=0.16 secs]


>From my understanding, initial mark pauses are supposed to be relatively
short, and usually shorter than remark pauses, but I don't have a remark
pause greater than 300ms.

Any help is appreciated.  Thanks,

Adam

--
Adam Hawthorne
Software Engineer
BASIS International Ltd.
www.basis.com
+1.505.345.5232 Phone
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/hotspot-gc-dev/attachments/20101014/891c9e30/attachment.html 
-------------- next part --------------
_______________________________________________
hotspot-gc-use mailing list
hotspot-gc-use at openjdk.java.net
http://mail.openjdk.java.net/mailman/listinfo/hotspot-gc-use


More information about the hotspot-gc-dev mailing list