RFR (S): 7080389: G1: refactor marking code in evacuation pause copy closures

Tony Printezis tony.printezis at oracle.com
Fri Aug 19 06:48:38 PDT 2011


On 08/19/2011 09:01 AM, Bengt Rutisson wrote:
> * At the two places in the do_oop_work method where you use the 
> do_mark_forwardee paramter you have comments saying that it is an 
> initial mark closure. This is correct, so I think that I would 
> actually prefer that the parameter was called something with inital 
> mark rather than having to have the comments.

Can I defend the name of the parameter? It is true that 
do_mark_forwardee is only true during an initial mark pause. But, during 
an initial mark pause only some of the specializations of the closure 
will have do_mark_forwardee set to true (the ones that scan roots). So, 
whether the do_mark_forwardee is true does not only depend on what kind 
of pause it is but also what kind of closure. So, IMHO, naming it 
"during initial mark" or something like that would actually be misleading.


More information about the hotspot-gc-dev mailing list